Eco v6 crashed or stopped working

Section for FAQs regarding i-Tree Eco (UFORE)

Moderators: i-Tree Support, i-Tree Team

Post Reply
azelaya
i-Tree Team
Posts: 369
Joined: Fri Jun 27, 2008 10:50 am

Eco v6 crashed or stopped working

Post by azelaya » Fri Aug 11, 2017 10:58 am

Post updated 01Nov2018
Some i-Tree Eco v6 users have reported random crashing or received the following errors:
  • i-Tree Eco v6 has stopped working.
  • OLEDB 14.0.7010.1000 is required, version 16.0.4266.1001 is installed.
  • OLEDB 14.0.7010.1000 is required to run i-Tree Eco. Install or reinstall the Microsoft Access Database Engine 2010 to correct this issue.
This is a known issue that has to do with the database “driver” that is installed with some versions Microsoft Office. This driver is called the “Microsoft Access Database Engine” and is intended for use by third party applications, like i-Tree Eco, which use Microsoft Access databases. Please note, this is a free driver provided by Microsoft and does not require the purchase of Microsoft Office or Microsoft Access. This driver does not interfere with, or affect the functionality of, existing installations of newer versions of Microsoft Office or Microsoft Access. Please follow the directions below to correct this issue:
  1. Uninstall Microsoft Access Database Engine 2010 (if installed):
    1. Open the Control Panel
    2. Open the Programs and Features
    3. Select the Microsoft Access Database Engine 2010
    4. Click Uninstall
    5. Complete the uninstall process
  2. Install the Microsoft Access Database Engine 2010:
    1. Download the installer from our support site:
      • If you have a 32 bit version of Microsoft Office installed, download the AccessDatabaseEngine.exe installer.
      • If you have a 64 bit version of Microsoft Office installed, download the AccessDatabaseEngine_x64.exe installer.
      • If you are not sure which version of Microsoft Office you have installed or do not have Microsoft Office, we recommend installing the 32 bit version.
    2. Run the installer and complete the installation.
Note: You may have to repeat this process if you install or upgrade Microsoft Office OR install Microsoft Windows updates after completing the above steps.

If your error message mentions "limited access rights" as an issue, you should ensure that you have full access rights to work in the folder where Eco and i-Tree were installed, along with the folder where you are trying to create your Eco project.
A member of the i-Tree Team
Dendrophobe
Posts: 1
Joined: Fri Jul 03, 2020 3:26 am

Re: Eco v6 crashed or stopped working

Post by Dendrophobe » Fri Jul 03, 2020 3:44 am

As of July 2020, the provided solution to fixing "OLEDB 14.0.7010.1000 is required to run i-Tree Eco" on Windows 10 (1903) no longer appears to work, despite Process Monitor showing iTree clearly accessing the DLLS, and the links provided only installing a version slightly newer than exactly 14.0.7010.1000, which is not available anywhere, because the only google result for "OLEDB 14.0.7010.1000" points right back to this page.

Image
azelaya
i-Tree Team
Posts: 369
Joined: Fri Jun 27, 2008 10:50 am

Re: Eco v6 crashed or stopped working

Post by azelaya » Tue Jul 07, 2020 12:10 pm

I checked with our Developers on the MS Access Database Engine 2010 file version and newer versions of 2010 file should work with current versions of i-Tree Eco. The current version of Eco is 6.0.21 in i-Tree suite 6.1.35.

The current i-Tree installation file and process checks for the MS-ADE2010 file and will download and install the Engine file from our server if not installed on a computer. The version that is installed is 14.0.7015.1000, which can be seen in control panel after the installation process. The original post stating "version 14.0.7010.1000 was required" - was originally intended as a minimum version for the MS-ADE2010 file acceptable for i-Tree Eco use. Microsoft has periodically update or released patches to the file and this is why the i-Tree installation fetches this from our server for consistency but newer versions should work. I tested an i-Tree install using the MS Support Center downloaded MS-ADE2010 file for an x64 machine and i-Tree installed and worked properly.
A member of the i-Tree Team
mgosnell
Posts: 2
Joined: Mon Sep 24, 2012 1:26 pm

Re: Eco v6 crashed or stopped working

Post by mgosnell » Mon Aug 10, 2020 3:29 pm

I also can't get past the following error and can't run i-Tree.
OLEDB 14.0.7010.1000 is required to run i-Tree Eco.
Install or reinstall the Microsoft Access Database Engine 2010 to correct this issue. For more information, see viewtopic.php?f=19&t=1360

I have MS Access database engine 2010 14.0.7015.1000 installed.
erbowlen@gmail.com
Posts: 1
Joined: Tue Aug 11, 2020 11:08 am

Re: Eco v6 crashed or stopped working

Post by erbowlen@gmail.com » Tue Aug 11, 2020 11:12 am

I have uninstalled and reinstalled Microsoft access multiple times. I have tried uninstalling i-Tree eco and reinstalling it. Nothing is working. I still get the error that OLEDB 14.0.7010 is required.
Jason.Henning
i-Tree Team
Posts: 222
Joined: Fri Dec 21, 2012 7:45 am

Re: Eco v6 crashed or stopped working

Post by Jason.Henning » Tue Aug 11, 2020 12:21 pm

There is an issue with a recent automatic Microsoft update that is causing this problem. Essentially, there is an entry in the computer's registry for the 32-bit version of the MS Database Engine however the update removes or disallows the 32-bit version. This issue will be resolved in the next release of i-Tree Eco as the software will automatically look for the correct version of the Database Engine. We expect that release to occur in the coming months. As an interim solution you may want to try opening your project on a different computer if possible.
If you have additional questions about this issue or need additional support please email the i-Tree Support Team at info@itreetools.org.
We will update this post when the new version of i-Tree Eco is released.
Thank you,
Jason
A member of the i-Tree Team
User avatar
dellings
i-Tree Team
Posts: 30
Joined: Thu Aug 21, 2008 2:12 pm

Re: Eco v6 crashed or stopped working

Post by dellings » Thu Aug 13, 2020 10:40 am

Microsoft published a new version of the Access 2010 Database Engine on 12/20/2019 on the Microsoft Download Center. The new version corrects security issues that have been addressed in several Windows updates. This new version has been updated to detect newer versions of Microsoft Office and prevent installation when the platform(x86/x64) of the driver does not match the platform of Microsoft Office that has been installed. Thus, if you have a 64 bit version of Office, you cannot install the 32 bit version of the new Access 2010 Database Engine and vice versa.

We have observed that recent versions of the Access 2016 Database Engine now register a 32 bit driver and a 64 bit driver. i-Tree Eco currently does not attempt to use the 64 bit driver if a 32 bit driver is registered. If you prefer to install the new version of the Access 2010 Database Engine driver from the Microsoft Download Center and were required to install the 64 bit version, manually running the 64 bit version of i-Tree Eco from the installation folder should allow i-Tree Eco to run. The next version of i-Tree Eco will attempt to use the 64 bit drivers if the 32 bit drivers are not present or are not supported.
Post Reply