i-Tree overwriting Tree ID field

Section for general i-Tree questions on installation, system requirements, registration, international use, etc.

Moderators: i-Tree Support, i-Tree Team

Post Reply
lariori
Posts: 1
Joined: Tue Mar 24, 2020 11:25 am

i-Tree overwriting Tree ID field

Post by lariori » Tue Mar 24, 2020 1:43 pm

I am attempting to import my data into the latest version of i-TreeEco v6.1.34. I have a ID field for each tree from our inventory that I want to use as the TreeID field. The values in the field are numeric, unique, and largely non-sequential. After importing the data from excel into i-Tree, it looks like the values have been overwritten into a sequential series, starting from the first number. For example, if the first few trees I imported had IDs 11, 14, 18; i-Tree Eco converted them to 11, 12, 13. Any ideas? If it's related, I'm also experiencing a lot of crashing related to "unhandled exceptions", but I was able to submit the data okay.
Jason.Henning
i-Tree Team
Posts: 205
Joined: Fri Dec 21, 2012 7:45 am

Re: i-Tree overwriting Tree ID field

Post by Jason.Henning » Tue Mar 24, 2020 2:23 pm

Thanks for the question.
The tree ID field in Eco is actually used by the program to keep track of trees and therefore has some specific database related requirements including sequential numbering. For users that have their own ID field we recently added the "User Tree ID" field. You can turn on this field by going to the "Project Configuration" tab and selecting "Project Definition" then clicking on the "Data Collection Options" tab. The "User Tree ID" field is at the bottom of the "Management Fields" column. The "User Tree ID" field are then available in selected reports for individual trees. You will likely want to make this change before importing data since that field with be left blank for any trees already entered in your project.
If you are having problems with the software crashing you may want to check out this forum post for a possible solution, viewtopic.php?f=37&t=5461&p=6780&hilit= ... gine#p6780. Also, make sure you are using the latest version of i-Tree Eco which includes the most recent bug fixes.
Thanks,
Jason
A member of the i-Tree Team
Post Reply